"Meltdown" and "Spectre"
Resolved
Evident has patched all of our systems as vendor patches came available and will continue to do so as new variants of "Meltdown" and "Spectre" are discovered and mitigated. As managing speculative execution side-channel attacks has become "the new normal", we are closing this event, but rest assured that Evident's security team will stay hard at work protecting our infrastructure and in turn, yours. If you have any questions or concerns around "Meltdown", "Spectre", or any of the recent variants, please reach out to security@evident.io.
Posted 7 months ago. Feb 15, 2018 - 17:56 PST
Monitoring
The recently disclosed security vulnerabilities dubbed “Meltdown” and “Spectre” (CVE-2017-5715, CVE-2017-5753, and CVE-2017-5754) have exposed a speculative execution vulnerability in specific Intel, AMD, and ARM processors. These processors are globally used in nearly every operating environment on the planet; both datacenter and cloud provisioned computational systems are vulnerable to these attacks.


The Evident.io SecOps team responded under our emergency response plan to the early disclosure of this issue and executed necessary remediary measures to protect all critical compute systems in Evident.io’s operating environment(s). While the vast majority of Evident.io’s compute systems have already been protected, there are a small number of secondary nodes that are scheduled to be patched immediately as the industry responds to these emerging threats. Our security team is on high alert to ensure the safety and security of our customers, their data, and their trust in our platform. We feel it is of the utmost criticality that security vendors around the globe make public statements about their response, and demonstrate that we are rallying around our customers and peers to mitigate the risks these emerging threats pose to our global internet community. Our team is proud to be in the ranks of cloud giants like Google, Amazon, and Microsoft in demonstrating our capability to respond and defend those customers who make us successful.
Posted 9 months ago. Jan 04, 2018 - 15:35 PST