We will be performing an e-deploy today to address performance concerns with Azure accounts.
Resolved
There are no longer any immediate performance issues with Azure.
Posted 4 months ago. Jun 08, 2018 - 11:34 PDT
Update
We are working on additional enhancements that we hope to release over the next weeks.
Posted 8 months ago. Feb 26, 2018 - 11:23 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Feb 22, 2018 - 12:51 PST