support@evident.io is down
Resolved
Both support@evident.io and ESP Contact Us Form are operational. If you encounter any further issues, please let us know by going to support.evident.io and open a ticket directly from the portal.
Posted 7 months ago. May 08, 2018 - 12:40 PDT
Investigating
Currently, support@evident.io is not is not functioning. Emails sent to support@evident.io will not reach ESP Support Portal and the contact form is also unavailable. We will update this message as soon as it is back up.
Posted 7 months ago. May 07, 2018 - 15:20 PDT